読者です 読者をやめる 読者になる 読者になる

この Qt バージョンのコードを生成できるコンパイラがありません。1つ以上のコンパイラを定義してください。

問題

MinGW をインストール済みなのに、Qt Creator の [オプション] > [ビルドと実行] > [Qt バージョン] に次のメッセージが表示される。

この Qt バージョンのコードを生成できるコンパイラがありません。1つ以上のコンパイラを定義してください。

f:id:renkin3q:20150916232836j:plain

環境

原因

MinGW にパスが通っていないため。

解決策

  1. 環境変数 PATH に MinGW のパス (C:\MinGW\bin) を追加する。
  2. Qt Creator を再起動して、キットのコンパイラMinGW を選択する。