Yocto

Multiple .bb files are due to be built which each provide jpeg

問題 レイヤーに meta-multimedia を追加して、vlc をビルドすると、次のエラーが表示される。 ERROR: Multiple .bb files are due to be built which each provide jpeg (poky/meta/recipes-core/jpeg/jpeg_8d.bb meta-openembedded/meta-oe/recipes-core/j…

Error, TMPDIR has changed location. You need to either move it back to /path/to/tmp or rebuild

問題 コピーした Yocto ディレクトリーで bitbake を実行すると、次のエラーが発生する。 ERROR: OE-core's config sanity checker detected a potential misconfiguration. Either fix the cause of this error or at your own risk disable the checker (s…

イメージファイルを圧縮させない

local.conf に次の行を書く。 IMAGE_FSTYPES = "sdcard" 参考文献 [meta-fsl-arm,V2] Add compression method to apply to SDCARD - Patchwork

root ユーザーのパスワードを変更する

local.conf に次の行を追加する。 INHERIT += "extrausers" EXTRA_USERS_PARAMS = "usermod -P mypassword root;" 参考文献 Change root parameters in recipe | NXP Community

Yocto レイヤーの作り方

レイヤーディレクトリーに移動して、yocto-layer create コマンドを実行する。 $ cd <meta-*** のあるディレクトリー> $ yocto-layer create <meta- の後ろに付ける名前></meta-></meta-***>

make[1]: *** [s-attrtab] Killed

問題 “gcc-cross-initial-arm” レシピのコンパイルがエラーで失敗する。 環境 AmazonLinuxAMI-2016.09 Yocto 2.2.1 (Morty) メッセージ make[1]: *** [s-attrtab] Killed 原因 メモリ不足により、OOM Killer に kill された。 解決方法 スワップを作る。 SWA…

ERROR: OE-core's config sanity checker detected a potential misconfiguration.

メッセージ ERROR: OE-core's config sanity checker detected a potential misconfiguration. Either fix the cause of this error or at your own risk disable the checker (see sanity.conf). Following is the list of potential problems / advisories…

WARNING: Host distribution ... has not been validated with this version of the build system; you may possibly experience unexpected failures. It is recommended that you use a tested distribution.

メッセージ WARNING: Host distribution “AmazonLinuxAMI-2016.09” has not been validated with this version of the build system; you may possibly experience unexpected failures. It is recommended that you use a tested distribution. 訳 警告: ホ…

error: Can't install nativesdk-qt4-tools-4.8.7-r0@x86_64_nativesdk: no package provides libQtDBus.so.4()(64bit)

問題 bitbake meta-toolchain-qt がエラーで失敗する。 メッセージ ERROR: meta-toolchain-qt-1.0-r7 do_populate_sdk: Unable to install packages. Command 'build/tmp/sysroots/x86_64-linux/usr/bin/smart --log-level=warning --data-dir=build/tmp/wor…

WARNING: ... do_package_qa: QA Issue: ... rdepends on ..., but it isn't a build dependency? [build-deps]

メッセージ WARNING: nativesdk-qt4-tools-4.8.7-r0 do_package_qa: QA Issue: nativesdk-qt4-tools rdepends on qt4-native, but it isn’t a build dependency? [build-deps] 訳 警告: nativesdk-qt4-tools-4.8.7-r0 do_package_qa: QA 問題: nativesdk-qt4…

ld: cannot find -lQtXml -lQtGui -lQtNetwork

問題 nativesdk-qt4-tools のビルド中にエラーが発生する。 メッセージ ./build/tmp/sysroots/x86_64-linux/usr/libexec/x86_64-pokysdk-linux/gcc/x86_64-pokysdk-linux/5.3.0/ld: cannot find -lQtXml collect2: error: ld returned 1 exit status make: *…